Z750 Clutch

Z, ZRX, ER & other naked bikes. Get naked in here.!

Z750 Clutch

Postby Mantis » Thu Aug 03, 2017 3:02 pm

The clutch on my '07 Z750 is no longer engaging. The lever pulls all the way back to the handlebars without resistance and I'm unable to change gears. All externally visible linkages appear to operate normally and it's a near new clutch cable. Over the last year or so the clutch friction point has moved progressively closer to the handlebars requiring incremental adjustment to the point where there is now no adjustability left. The bike itself has nearly 95,000km on the clock since I bought it new and has never missed a service. The clutch "failure" and loss of resistance occured this morning while changing into 4th gear at about 5000rpm during expressway riding (I'm a slow old fart and treat my bike with kid gloves as I'm not in any way mechanically inclined). Any ideas or suggestions would be greatly appreciated before I send it off to be repaired.
Mantis
Newbie
 
Posts: 6
Joined: Mon Sep 29, 2008 9:30 am
Location: Glenfield, NSW
Bike: Z750
State: New South Wales

Re: Z750 Clutch

Postby webbo » Sun Sep 24, 2017 11:55 pm

Sounds like a new clutch is needed
webbo
Newbie
 
Posts: 3
Joined: Sun Sep 24, 2017 11:44 pm
Bike: Other Kawi
State: New South Wales

Re: Z750 Clutch

Postby Mantis » Wed Sep 27, 2017 8:20 pm

Turns out it was an actuating pushrod-type thing within the clutch cover. The end of it sheared off so that it wasn't fully engaging. My local bike shop was eventually able to acquire a new one and install it so that it's good as new. Hopefully it will last another 100,000km. :D
Mantis
Newbie
 
Posts: 6
Joined: Mon Sep 29, 2008 9:30 am
Location: Glenfield, NSW
Bike: Z750
State: New South Wales


Return to Z, ZRX, ER6 & other nakeds

Who is online

Users browsing this forum: Google [Bot] and 6 guests